Topic: 20v ecu light on - but no error code- help please

howsit guys

did a 20v swop. but the engine light is coming on when idling if i rev a few times
or drive the car over 3000rpm

checked the error codes - nothing

where do i start?
how do i test if the diagnostics is working?

http://i89.photobucket.com/albums/k210/mayurh/22671_32659.jpg

Re: 20v ecu light on - but no error code- help please

Thats new to me. Looking forward for the aswear as well

96 Levin AE111 20v JDM

Re: 20v ecu light on - but no error code- help please

What management you using or is it original ECU?

1995, 20v, Dictator, SRI, 50mm exhaust
95wkw 145nm @ JVS Tuning Cape Town on 24-10-13
http://i356.photobucket.com/albums/oo4/morollaTRD/DSC_0576-1.jpg

Re: 20v ecu light on - but no error code- help please

morolla wrote:

What management you using or is it original ECU?

stock 20v ecu guys

Last edited by mayurh (2013-11-22 10:01:20)

http://i89.photobucket.com/albums/k210/mayurh/22671_32659.jpg

Re: 20v ecu light on - but no error code- help please

knock sensor is faulty test with an other one or your wiring harness is damaged the wire to your knock sensor broken somewhere

7AGE 6SPD: 2B1 Built & Mapped by Autotrix   "Best 1/4mile time 14.2sec @ Mtuba (MSA EVENT) "
Don't INJURE what you can't KILL!!!                           
Update : 5 May 2013 14.2@161kmph (achieved time with car having a miss fire issue)
http://i632.photobucket.com/albums/uu42/20plenty/7age_2_zps44a6e6ab.jpg
What did the 1 V-tec supporter say to the other V-tec supporter?
NB:Remember!!!
If the 20vs 1st off the line we'll say he JUMPED THE V-TEC!
but if the VTEC's 1st off the line we'll say he OUT LAUNCHED THE 20V!
sweeeeeet!!! we cant lose this way.......(^_^)

Re: 20v ecu light on - but no error code- help please

getting knock sensor error when mech tried it again
anyone in jhb got one i can use to test?

http://i89.photobucket.com/albums/k210/mayurh/22671_32659.jpg

Re: 20v ecu light on - but no error code- help please

check insulation of wiring as that is also the reason why the error comes up. Check for continuity with an ohmmeter on the sensor if there is it's busted.

Re: 20v ecu light on - but no error code- help please

Twincam-wp wrote:

check insulation of wiring as that is also the reason why the error comes up. Check for continuity with an ohmmeter on the sensor if there is it's busted.

thanks a lot dude
will do that and give feedback

http://i89.photobucket.com/albums/k210/mayurh/22671_32659.jpg

Re: 20v ecu light on - but no error code- help please

Check wiring for knock sensor plug most of the time its the plug
Mine looked like it was plug in but it wasn't plugged it in properly and light sorted

http://i293.photobucket.com/albums/mm66/DA2CAMS/Copyof1-2.pngCAN'T TOUCH IT,U MUST JUST WISH FOR IT
TRD PRESIDENT

Re: 20v ecu light on - but no error code- help please

Check wiring for knock sensor plug most of the time its the plug
Mine looked like it was plug in but it wasn't plugged it in properly and light sorted

http://i293.photobucket.com/albums/mm66/DA2CAMS/Copyof1-2.pngCAN'T TOUCH IT,U MUST JUST WISH FOR IT
TRD PRESIDENT