Topic: Car not ravving past 3k

today was changing park lights and I removed the battery to reach the one on the left. After I finished did not start the car. After 2 hours starts the car but was surprised
Engine light was on. Switch off and on again it still there and when I try to drive it does not rev past 3k. Checked Maf sensor it was tight and cleaned it put it back still same thing. Is it possible Maf sensor is dead?

63mm stainless(Power Flow)
Injen CAI
Viper Branch
Short Shifter

Re: Car not ravving past 3k

your maf sensor is blown

2011 Alfa Romeo MIto QV Sport - 135kw & 301nm on the wheels
Race Chip Pro2, Magnetti Marelli Rear Diffuser, 76mm Downpipe, 63mm Twinport Exhaust,
Power Flex Bushes, Upgraded DRL Headlights, Full Custom Intake, Upgraded Intercooler, Upgraded Wastegate & BOV.
"A woman without curves is like a road without bends, you might get to your destination quicker but the ride is boring as hell'

http://i1124.photobucket.com/albums/l575/spook20vt/IMG-20131104-00493_zpsf5b0a3dc.jpg

Re: Car not ravving past 3k

2zz-Spook wrote:

your maf sensor is blown

Was also thinking the same. Guys around JHB anyone can sell me one?

63mm stainless(Power Flow)
Injen CAI
Viper Branch
Short Shifter

Re: Car not ravving past 3k

Vikzela wrote:
2zz-Spook wrote:

your maf sensor is blown

Was also thinking the same. Guys around JHB anyone can sell me one?


Yeah it  was. Maf sensor replaced it and everything back to normal. Got one for R400 Toyo parts Pretoria. Toyota is around R2050.

63mm stainless(Power Flow)
Injen CAI
Viper Branch
Short Shifter