Topic: new engine using oil??

Hi guys please help with some advice. .my blacktop motor is completely redone from bottom to top done by engineers and I used the best quality parts. .what is strange to me now is the has 7000km on and using oil again. I drove down from jhb to cpt on sunday and checked my oil was below half on the dipstick. Im using 20w50 mobil xhp what could be the reason for this? Rings didnt bed perhaps? Advice would be appreciated because im on the verge of selling im not up for another oil problem

4age 20v

Re: new engine using oil??

Did you check for leaks?

Remember, the 6speed 20V came with an oil cooler.

Does your car have one?

Thats about a pint for >1000kms? Not too bad. A new motor will consume oil as the rings bed

Its not your top speed that counts but how quick u get to it...
05 - XRSi - 118WKW (Reef) - 15.7 @ Tarlton - 3.12.2010

01 - MR2 Turbo - 253KW ATF (Reef) - 14.4 @ Tarlton - 18.11.2011 - new time TBC

06 - Tuna 4x4
http://i30.photobucket.com/albums/c344/Diesel111/sig2_zpsm60s5g3e.jpg

Re: new engine using oil??

Thanx for the feedback I have an oil cooler yes an no leaks at all anywhere on the motor I understand that is should consume oil as the rings bed but after 7000km shouldnt it have bedded already oh and I think my o2 sensor is shot could at have an influence on oil consumption?

4age 20v

Re: new engine using oil??

Shot o2 sensor can lead to over-fueling and in the long run a term called bore-wash.. were the fuel runs in the bore mixing with oil.. weakening it , the oil does not lubricate it sufficiently wearing down the bore..eventually  leading to oil consumption...  after 7000km is your oil golden brown or black in colour?

Bring it!
Rxi 2002  ???wkw

Re: new engine using oil??

if your motor shows half now for the entire 7000km, then you have very good oil consumption in my opinion and a 20v generally uses oil

Re: new engine using oil??

Thanx rxi18 for the advice, no twincam ive topped up in between as well, rxi18 my oil is black in color

4age 20v

Re: new engine using oil??

have you done an oil change after the first 1000kms?

Its not your top speed that counts but how quick u get to it...
05 - XRSi - 118WKW (Reef) - 15.7 @ Tarlton - 3.12.2010

01 - MR2 Turbo - 253KW ATF (Reef) - 14.4 @ Tarlton - 18.11.2011 - new time TBC

06 - Tuna 4x4
http://i30.photobucket.com/albums/c344/Diesel111/sig2_zpsm60s5g3e.jpg

Re: new engine using oil??

Yes

4age 20v

Re: new engine using oil??

its doing 7000kms-ish now.. how long was it before your last oil change...   also was your cpt trip with a full-load?

Bring it!
Rxi 2002  ???wkw

Re: new engine using oil??

Did 1000km changed, drove another 1000 then changed again.

4age 20v